16

Installation Kernel 3.0.6 sur Ubuntu 11.04 10.10 10.04

Bonjour,
voici un article sur comment installer le tout dernier kernel stable 3.0.1 sur Ubuntu 11.04, 10.10 ou 10.04(je n’ai pas testé sur Debian mais je penses que ça doit être la même méthode)

Dans cet article nous allons voir une méthode dite « simple » car pas de compilation à l’horizon mais juste du dpkg.
Allez c’est parti! :-)

pour le kernel 3.1 c’est ici -> http://memo-linux.com/installation-sous-ubuntu-du-kernel-3-1/
pour le kernel 3.3 c’est ici -> http://memo-linux.com/installation-kernel-3-3-sous-ubuntu-12-04-lts/

on commence par ce placer dans le répertoire ou nous allons télécharger les « headers »:

$cd /home/fred/download

et nous allons télécherger Linux-headers_all.deb, Linux-headers-generic_i386.deb et Linux-image-generic_i386.deb pour la version 32 bits

$wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/linux-headers-3.0.1-030001_3.0.1-030001.201108060905_all.deb
--2011-08-17 17:08:06--  http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/linux-headers-3.0.1-030001_3.0.1-030001.201108060905_all.deb
Connexion vers 172.24.24.228:8080... connecté.
requête Proxy transmise, en attente de la réponse... 200 OK
Longueur: 11211604 (11M) [application/x-debian-package]
Sauvegarde en : «linux-headers-3.0.1-030001_3.0.1-030001.201108060905_all.deb»

87% [=================================================================================================================================>                  ] 9 855 647    271K/s  eta 6s

et la même chose pour les deux autres:

$wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/linux-headers-3.0.1-030001-generic_3.0.1-030001.201108060905_i386.deb
$wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/linux-image-3.0.1-030001-generic_3.0.1-030001.201108060905_i386.deb

si 64 bits voici les liens:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/linux-headers-3.0.1-030001_3.0.1-030001.201108060905_all.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/linux-headers-3.0.1-030001-generic_3.0.1-030001.201108060905_amd64.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.1-oneiric/linux-image-3.0.1-030001-generic_3.0.1-030001.201108060905_amd64.deb

ensuite l’installtion proprement dite:

Pour linux-headers

$sudo dpkg -i linux-headers-3.0.1-030001_3.0.1-030001.201108060905_all.deb

Pour linux-headers-generic

$sudo dpkg -i linux-headers-3.0.1-030001-generic_3.0.1-030001.201108060905_i386.deb

Pour linux-image-generic

$sudo dpkg -i linux-image-3.0.1-030001-generic_3.0.1-030001.201108060905_i386.deb

une fois que c’est fait, on reboot notre machine et on croise les doigts:

$sudo init 6

si tout va bien, notre système tourne avec le dernier kernel stable en date:

$uname -r
3.0.1-030001-generic

Voilà c’est fini, en espérant que ça fonctionne bien chez vous :-)

Mise à jour:
voici le lien pour la version 3.0.3 http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.3-oneiric/

MISE A JOUR:
sur le même principe vu plus haut, voici le lien pour avoir le kernel stable: 3.0.6

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.6-oneiric/


D'autres articles :

Partager cet article:

Il est aussi possible de Flattr l'article en cliquant sur le dernier bouton, pour me payer une Duff!

fred

Autodidacte, technicien informatique système et réseau. Utilisateur au quotidien de GNU/Linux. Écoute et joue du Punk'Hard'Blues'n'Roll et me déplace tous les jours avec mon fidèle destrier, qui est le magnifique ZRX1100.

16 Comments

  1. Bonjour

    j’ai suivi les étapes pas à pas.Tout c’est bien déroulé et pourtant le Kernel 3.0.1 ne s’installe pas après redémarrage.J’ai la version 2.6.38.11.Est-ce la raison de l’échec? Que dois-je faire?
    Merci de votre aide

    • Bonjour raftu!
      lorsque tu as suivie les étapes, as-tu eu des messages d’erreurs?
      lors du reboot, as-tu accès au menu du Grub?
      peux-tu me retourner le résultat de la commande ls dans /boot

      sinon ta version d’origine du kernel n’est pas la raison…

  2. il faut héberger l’image pour qu’elle soit visible sur internet…
    je te contact par mail ;-)

  3. Bonjour,

    J’arrive sans problème depuis ma 11.04 à installer les nouveaux noyaux (je passe par Gdebi, chacun son truc). Le seul souci que je rencontre est la perte des consoles virtuelles Ctrl+ Alt +Fn.

    Une piste à proposer ?

  4. Salut 89paladins!
    ne cherches pas, ça vient de Gdebi…
    ok elle était facile :-)

    la perte des consoles c’est à chaque mise à jour?
    les consoles sont-elles activent dans le fichier

    /etc/default/console-setup

    as-tu cette ligne:

    ACTIVE_CONSOLES="/dev/tty[1-6]"
    

    est-ce que le process tourne?

    ps xa | grep tty
    

    peut-être un problème driver graphique, t’as quoi comme carte?
    et quel noyau tu install?
    le tout dernier 3.2?(si c’est le cas j’ai rencontré des problèmes avec mon driver nvidia)

    • Merci pour ta réponse.
      J’ai testé avec les 3.2.6, 3.2.7, 3.2.8 et 3.2.9.
      Tout est OK pour les commandes que tu m’as proposées, les processus affectés aux consoles TTY sont bien présents. Mais c’est toujours pareil : pas de login proposé…
      En fait, quand le noyau démarre, je vois tout de suite si ça fonctionne (comme avec le 2.6.38) au splash.
      Pour les noyaux 3.2.x, pas de splash…
      Ma carte graphique est Nvidia 6800GT avec les pilotes propriétaires 295.20.
      Pour ne pas avoir des rectangles baveux à la place des caractères dans les messages système, quand le noyau démarre, je passe les paramètres suivants au noyau : nomodeset vga=791. Mais même sans (c’est-à-dire juste quiet splash), c’est pareil.
      J’ai aucune erreur dans Xorg.0.log, ni dans dmesg, ni kern.log.
      Je commence à sécher :(

  5. quel version de grub utilises-tu?
    car avec Grub2 ce n’est pas vga qui faut utiliser mais set gfxpayload
    et si tu ulises le pilote nv au lieu du propriétaire, ça change quelque chose?

    vois-tu le menu du Grub?
    si oui, au menu tape sur « c » puis la commande vbeinfo
    cela va te donner les résolutions supportées

    • Un grand merci, Fred !
      Je n’avais plus en tête l’histoire du Grub. C’est bien la version 2 et avec le gfxpayload en place, ça tourne en en 3.2.9 :)
      Pour le pilote nv, je l’ai utilisé tant que j’ai pu, mais avec Google Earth ou Diablo 2, j’ai dû passé au pilote nvidia (avec KMS désactivé) pour retrouver une fluidité.
      Quels progrès ils ont fait pourtant sur le pilote nv, c’est impressionnant !
      Quant à vbeinfo, bah, figure-toi qu’une fois la touche entrée appuyée, pfft, que dalle, comme si j’ouvrais une console avant avec VGA=791. Obligé de faire un Ctrl+Alt+Suppr pour redémarrer.
      Je vais regarder le tuto dans le forum Ubuntu avec les histoires de v86d voir si ça résout le problème vbeinfo, d’autant plus que le logo Ubuntu n’est pas Ni-Cr.
      Dernier point : (WW) Open ACPI failed (/var/run/acpid.socket) dans le Xorg.0.log. Je n’ai rien trouvé par Google ou sur le forum Ubuntu. En revanche, si justement je fais un Ctrl+Alt+Fx et que je reviens en TTY7, dans le journal, j’ai systématiquement un beau Open ACPI successful (/var/run/acpid.socket).
      Là, c’est pareil, je sèche (sauf que ce n’est pas rédhibitoire comme mon premier problème).
      Encore merci.

  6. De rien ;-)

    (WW) Open ACPI failed (/var/run/acpid.socket) dans le Xorg.0.log

    hum, je soupçonne quand même un problème avec le driver nvidia :/
    tu n’as que ce passage comme log d’erreur?

    • J’ai aussi :
      (WW) Unable to get display device CRT-0’s EDID; cannot compute DPI from CRT-0’s EDID.

      Je lui ai pourtant mis dans la section Screen du xorg.conf : Option « UseEDID » « FALSE »
      Apparemment, il n’en tient pas compte…

      Pour (WW) Open ACPI failed (/var/run/acpid.socket), en cherchant in english dans google, j’ai trouvé que c’était un bug récurrent qui se balade depuis des années…

      Pour vbeinfo qui n’affichait plus rien, il fallait mettre dans Grub plusieurs résolutions possibles à la ligne GRUB_GFXMODE=…

      Merci encore ;)

  7. Service de déterrage boujour :-)

    Utilisateur de Lucid Lynx (Ubuntu 10.04 LTS) je souhaiterais rester à jour niveau système sans passer par les nouvelles 12.04 LTS et consorts…

    Pensez-vous qu’une compilation du dernier noyau me permettrait d’avoir un système sécure tout en conservant le Lucid Lynx que je trouve agréable et fonctionnel (gnome 2, etc)?

    Merci de votre attention.

  8. Salut Phoenix,

    je compatis pour dire que la Lucid était bien la dernière version sympa d’Ubuntu!

    Oui tu vas pouvoir compiler le dernier noyau Linux LTS, le problème va être que l’ensemble du système ne sera pas à jour et avec d’éventuelles fails de sécurité.

    Si tu veux resté avec du Gnome 2 soit passer sur l’environement Mate(Fork de Gnome2) ou passer à Gnome 3 en utilisant l’environnement Gnome classic. Cependant, Gnome3 sera beaucoup plus lourd que Gnome 2.

    Je fûs confronté au même souci, j’ai cherché une alternative en testant quelques environnement et autre distributions sans être totalement convaincu car les habitudes sont très dur à changer. Jusqu’au jour, ou j’ai découvert Manjaro sous Cinnamon et là, j’avais enfin trouvé mon bonheur :-)

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *